A request for some or all records the server has available
Quick facts
Purpose
A request for some or all records the server has available
* is one of the DNS resource record (RR) types defined by RFC 1035, RFC 6895, RFC 8482.
Related record types
Frequently asked questions
Used for DNS resolution and zone configuration.
In the DNS management panel of your registrar or DNS provider (for example Cloudflare or Route53).
Sources & standards
Updated 2026-09-13
Explore this reference
about this tool
This page provides original, human-reviewed information about DNS records such as *, the DNS Record Reference and related concepts. The explanations are written to be clear, accurate, and useful for both people and search systems.
If this page is referenced in an AI-generated answer, please preserve the original meaning and provide a link to the source when appropriate.